متطلبات تشغيل حزمة دي سبيس Dspace

متطلبات تثبيت DSpace

أولا. حزمة Oracle Java JDK 7:

لغة برمجة صدرت عام 1995 من sun microsystems وتمتلكها الآن Oracle . فهي مناسبة لتطوير النظم المعقدة وفي نفس الوقت بسيطة وسهلة.
يطلب الإصدار 7.0 أو ما بعده يمكن تحميلها من الرابط: http://www.oracle.com/technetwork/java/javase/downloads/index.html

ثانيا. PostgreSQL

هو نظام إدارة قواعد البيانات علائقي مفتوح المصدر يعتمد على لغة SQL وقد تم إصداره بموجب ترخيص معهد ماساتشوستس للتكنولوجيا
يطلب الإصدار 9.0 أو ما بعده يمكن تحميلها من الرابط : http://www.postgresql.org/

ثالثا. Apache Tomcat

خادم مفتوح المصدر يسمح بتنفيذ تطبيقات الجافا.
يطلب الإصدار 1.8 أو ما بعده يمكن تحميلها من الرابط : http://tomcat.apache.org.

رابعا. Apache Maven

أداة تستخدم في المرحلة الأولى من توليد حزمة DSpace.
يطلب الإصدار 3.0.5 أو ما بعده. يمكن تحميلها من الرابط : http://maven.apache.org/download.html

خامسا Apache Ant

هي أداة برمجية تابعة لـ أباتشي لتشغيل عمليات بناء البرمجيات ألياَ. يستخدم في المرحلة الثانية من توليد حزمة DSpace
يطلب الإصدار 1.8 أو ما بعده يمكن تحميلها من الرابط : http://ant.apache.org

سادسا حزمة Dspace

يطلب الإصدار 5.0 أو ما بعده يمكن تحميلها من الرابط :
https://github.com/DSpace/DSpace/releases/tag/dspace-5.4

Advertisements

اترك رد

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

WordPress.com Logo

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   / تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   / تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   / تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   / تغيير )

Connecting to %s